问题起因:因为更新了android studio导致的不兼容

![1621992348366](D:/else3/weixindownload/WeChat Files/wxid_46iv8yn5hu4n22/FileStorage/File/2021-05/不兼容的问题.assets/1621992348366.png)

使用框架:implementation ‘com.flyco.tablayout:FlycoTabLayout_Lib:2.1.2@aar’
该框架种由于含有support v4组件。导致更新后的androidX不兼容该框架。
现在考虑解决问题:替换该框架中的V4组件。或者换一个框架。
奇怪点:未更新android studio前是可以兼容的。当时也是andoridX
需要搞清楚:更新该新版本。有哪些变动。怎么样处理。

最后解决办法,在gitee的该框架介绍中,发现了需要配置某选项为true即可。

如下说明了为了兼容AndroidX 需要在gradle.properties中添加如下选项即可:

![1621992265643](D:/else3/weixindownload/WeChat Files/wxid_46iv8yn5hu4n22/FileStorage/File/2021-05/不兼容的问题.assets/1621992265643.png)